Author Topic: Waiting for device  (Read 2338 times)

Deker

Waiting for device
« on: May 12, 2023, 05:39:23 pm »
I've been using my trusty Samsung Tab4 SM-T230 running Android 4.4.2 which worked with my PAW faultlessly for several years.
Now I've "upgraded" to a Samsung A7 lite SM-T225 Android 13, I keep getting the "waiting for device message" in Sky Demon, normally after about 20 to 30 mins from start up.
Usually need to turn the tablet wifi off and back on, but once the problem starts, it repeats at random intervals. It's been like this for the past 6-9 months and not changed behaviour even with several recentish PAW firmware updates.

I'm pretty sure its a tablet issue as I've been in P2 seat with P1 running his Apple table, my Samsung flags the message but the Apple functions properly. I've also repeated the test with my phone and tablet connected, tablet flashed the message but phone continues to work fine.

As far as i can tell, bth tablets are configured the same.

Any suggestions?

ATB
Deker

steveu

Re: Waiting for device
« Reply #1 on: May 12, 2023, 09:20:02 pm »
Is there an issue if the tablet is connected to a Wifi network with no Internet access? Newer versions of Android can rear up about this.

Does the tablet have a problem with connecting to open networks?

Both things to Google for with your particular model.

You can remove the open networks theory by setting a password for the PAW Wifi, then if it makes no difference, clearing it again.

Do you have Internet access/iGrid?

Tablet firmware/Android fully up to date?

exfirepro

Re: Waiting for device
« Reply #2 on: May 13, 2023, 07:20:09 am »
I've been using my trusty Samsung Tab4 SM-T230 running Android 4.4.2 which worked with my PAW faultlessly for several years.
Now I've "upgraded" to a Samsung A7 lite SM-T225 Android 13, I keep getting the "waiting for device message" in Sky Demon, normally after about 20 to 30 mins from start up.
Usually need to turn the tablet wifi off and back on, but once the problem starts, it repeats at random intervals. It's been like this for the past 6-9 months and not changed behaviour even with several recentish PAW firmware updates.

I'm pretty sure its a tablet issue as I've been in P2 seat with P1 running his Apple table, my Samsung flags the message but the Apple functions properly. I've also repeated the test with my phone and tablet connected, tablet flashed the message but phone continues to work fine.

As far as i can tell, bth tablets are configured the same.

Any suggestions?

ATB
Deker


Hi Derek,

Definitely sounds like a WiFi connectivity issue to me, but of course not easy to determine exactly what.

Remind me - are we talking Rosetta or PAW Classic?

When you go to 'turn the tablet WiFi off and back on' do you notice whether it has connected to something else in the plane - such as another phone? If so, it might just be a question of adjusting the PAW WiFi strength / channel from the default settings. I have just dealt with a similar issue for a mate running an 'upgraded' Classic on a Pi3 board (so not simply a faulty WiFi dongle) into an full size iPad in his Emeraude - which we seem to have resolved by reducing the PAW WiFi power from 50mW to 20mW. Take a note of the defaults before you make any changes and just change one field at a time and test fly before changing anything else - and remember to try both reducing the WiFi strength and increasing it. I can't remember, but you may also have to reboot your PAW each time for the changes to take effect.

Let us know if that helps.

Best Regards

Peter

Deker

Re: Waiting for device
« Reply #3 on: May 14, 2023, 12:48:38 pm »
Thanks for the reply Steve and Expo.

My PAW classic has a password, so not an open network problem.
Samsung update the tablet more often than I use it :-)
I have been using i-grid intermittently, I haven't seen a correlation but will monitor that.

When I ON-OFF-ON the wifi it always connects to PAW, I don't see any other hotspots and have intentionally turned all other devices off which may have been more attractive to my tables wifi
Often it will connect automatically after random times from a few seconds upwards.

Maybe a "forget network" and re-enter the PAW login credentials is worth a try?

Strange thing is it always occurs after about 20 mins or more after take off.

ATB
Deker


Admin

Re: Waiting for device
« Reply #4 on: May 14, 2023, 02:22:36 pm »
Android has a habit of doing this when any power/battery saving options are enabled
Try disabling

steveu

Re: Waiting for device
« Reply #5 on: May 14, 2023, 02:30:54 pm »
Android has a habit of doing this when any power/battery saving options are enabled
Try disabling

Ditto data saving or compression...
« Last Edit: May 14, 2023, 02:42:17 pm by steveu »

Deker

Re: Waiting for device
« Reply #6 on: May 14, 2023, 05:38:08 pm »
I updated the PAW firmware to 20230512
Had a quick pootle about this afternoon, got the message after about 15mins, reconnected automatically and was Ok for rest of the flight.
I've just checked, and power saving is off.
Running android 13

PAW is set to UDP.
Phone worked as second screen without wifi dropout.

Will check the wifi power next time.

ATB
Deker

dave_kent

Re: Waiting for device
« Reply #7 on: May 25, 2023, 07:09:07 pm »
I had the same problem today a couple of times - a warning that connection had been lost, but no discernible problem in Skydemon.  The logs were intact as a single log, and it seemed to recover immediately.  I wonder if this is a very minor timeout issue, that was hidden from us before Tim introduced the audio alert to loss of connection in SD recently?

Dave

Deker

Re: Waiting for device
« Reply #8 on: May 28, 2023, 07:35:56 am »
Flight on 27th/5/23 after clearing all the wifi settings (forget networks) on my tablet resulted in no change.
Connection was OK for about 15mins, then multiple "waiting for device banner" warnings but connected automatically in 1-2 seconds.
Then after about 8 disconnections, it stubbornly refused to auto connect so had to toggle wifi on/off/on.
Phone operating perfectly throughout.

Might check the PAW wifi power next time.

Brooklands

Re: Waiting for device
« Reply #9 on: June 05, 2023, 06:55:06 pm »
I encountered this problem yesterday with my new Samsung Galaxy Tab A7 Lite (SM-T220 model, Android 13) and my PAWClassic with the latest PAW software. 

When I connected the tablet to the PAW wifi it detected that there wasn't an internet connection and asked if I still  wanted to connect which I told it to do.  As soon as I told Skydemon to use pilotware it connected then proceeded to loose the connection and re-connect every couple of minutes.  I'd disabled power saving on the tablet and any other settings that  I thought may affect it.  I tried changing the wifi power settings on the PAW but it made no difference

As the PAW wifi connection was unusable I then tried connecting it to my Skyecho and had no disconnects at all (during a one hour flight) which makes me think that it maybe something in the PAWwifi setup.

I've done some digging today and had a look at the wifi settings on the Skyecho and its got the wifi channel set to auto (and was using channel 11).  I tried setting the PAW to channel 11 and the connection in Skydemon stayed up for about 10 minutes before I got the connection lost message so some improvement.  I'm going to try setting the wifi channel to auto and see what happens. 

I'd like to try changing the mode setting but as I don't know what it does I'm concerned that I may lock myself out of the PAW.

One other thing I noticed was that the tablet seems to run some sort of check on the wifi connection every minute or so

My old Google Nexus 7 (Android 6) had no issues at all so I was able to use that.

Brooklands

Admin

Re: Waiting for device
« Reply #10 on: June 06, 2023, 02:48:49 pm »
I encountered this problem yesterday with my new Samsung Galaxy Tab A7 Lite (SM-T220 model, Android 13) and my PAWClassic with the latest PAW software. 

When I connected the tablet to the PAW wifi it detected that there wasn't an internet connection and asked if I still  wanted to connect which I told it to do.  As soon as I told Skydemon to use pilotware it connected then proceeded to loose the connection and re-connect every couple of minutes.  I'd disabled power saving on the tablet and any other settings that  I thought may affect it.  I tried changing the wifi power settings on the PAW but it made no difference

As the PAW wifi connection was unusable I then tried connecting it to my Skyecho and had no disconnects at all (during a one hour flight) which makes me think that it maybe something in the PAWwifi setup.

I've done some digging today and had a look at the wifi settings on the Skyecho and its got the wifi channel set to auto (and was using channel 11).  I tried setting the PAW to channel 11 and the connection in Skydemon stayed up for about 10 minutes before I got the connection lost message so some improvement.  I'm going to try setting the wifi channel to auto and see what happens. 

I'd like to try changing the mode setting but as I don't know what it does I'm concerned that I may lock myself out of the PAW.

One other thing I noticed was that the tablet seems to run some sort of check on the wifi connection every minute or so

My old Google Nexus 7 (Android 6) had no issues at all so I was able to use that.

Brooklands

This is a useful bit of information. The important bits are as follows

1. The SkyEcho stayed connected
2. The tablet seems to run some sort of check on the wifi connection every minute or so
3. My old Google Nexus 7 (Android 6) had no issues at all so I was able to use that.

OK, why is this interesting - well its as follows.

When PilotAware accepts a connection it advertises itself as not having a router capability, ie it tells your device you "cannot connect to the internet through me", this allows a cellular device the opportunity to connect to the internet through its 3g/4g connection rather than attempting to use the WiFi (PAW) connection

My understanding is that SkyEcho does not have this setting, and therefore any WiFi client thinks it can access the internet - even though it cannot

The fact that your older device does not make this check, sounds like the clincher.
My Android device does not seem to care either

Do you have iGrid ?
If so can you enable the router option when connected to iGrid and see if that satisfies the tablet that it can see the internet, and does not therefore attempt to go looking for another connection

some additional searching
https://android.stackexchange.com/questions/130265/stay-connected-to-specific-wifi-which-has-no-internet

also this post
https://android.stackexchange.com/questions/110471/disable-internet-access-detection-of-wifi-networks
says to disable 'Avoid poor connections'

« Last Edit: June 06, 2023, 02:56:20 pm by Admin »

Deker

Re: Waiting for device
« Reply #11 on: June 17, 2023, 05:58:15 pm »
Short trip to Leicester today, got the usual "waiting for connection" message after about 20 mins.
Returning after a chance meeting and chat with Brooklands at Leic' I set as the "GSM" hotspot and no drop out.
PAW has always been set to "Router mode".

Will repeat the test on next trip to check if this wasn't a fluke.
If this works, can PAW spoof a GSM connection even when a real GSM is not available?

ATB
Deker.

Ian Melville

Re: Waiting for device
« Reply #12 on: June 17, 2023, 07:20:19 pm »
Not directly related to PAW, but a similar issue.

This week I had to record a presentation and planned to connect my laptop to my camera. Create a WiFi hotspot on the laptop and connect the camera to it. Tested it at home and all worked well and I was able to monitor the recording and adjust it as needed. At the venue there is no Wifi,  and I do not have GSM in the laptop. When I tried to activate the hotspot previously created, the laptop reported that it cannot see the internet, so failed the Hotspot >:(

Under Windows you can configure this from the command line or install a Microsoft app called 'Hotspot lite' to resolve this issue. I suspect there are other fixes for various OS. Not tried either yet

Brooklands

Re: Waiting for device
« Reply #13 on: June 18, 2023, 04:03:14 pm »
An update.

I haven't been able to reproduce the problem where the new tablet kept dropping the connection to the PAW as soon as I told SD to use it.

On the trip to Leicester yesterday I had my old (Android 6) tablet connected to the PAW and my new tablet (Android 13) connected to the Skyecho.  Neither lost the connection.

On the way back I set up the PAW with iGrid, but missed enabling the router setting and the new tablet lost the connection after about 20 minutes but reconnected immediately.

I've done some more tests today at home with the PAW set up with iGrid via my broadband connection but SD is still loosing the connection.  Its ok for about 15 - 20 minutes the I get the connection lost audio message but the table reconnects almost immediately it then goes another 10 -1 15 minutes before dropping again and reconnecting before going into a phase where it constantly drops and re-connects, sometimes immediately and sometimes after a few seconds.  I also re-ran the test with the Skyecho and the connection stayed up until I stopped the test after 40 minutes. 

I've had a look at the two links but I don't have the "Avoid poor connections" option in the Advanced settings and I'd rather not root the device which the others suggestions seem to need.

Brooklands

Deker

Re: Waiting for device
« Reply #14 on: June 24, 2023, 08:31:35 pm »

Will repeat the test on next trip to check if this wasn't a fluke.
If this works, can PAW spoof a GSM connection even when a real GSM is not available?

ATB
Deker.

Same test but today I got the "waiting for device message" even with GSM connection.
This is becoming a real pain.