Author Topic: Network Settings page not showing the iGRID part - Now Resolved  (Read 1002 times)

Gary Nelson

I just received a new Wifi dongle from PAW. However the expected new lower part of the Network page is not showing. NB: I was very careful to insert the dongle fully into the only remaing free USB port on my Rosetta (one of the 4 is used to input a Flarm mouse).  I attach the following screenshots and any help would be appreciated:

1. Network Page - showing the lack of the expected new "hotspot" part of this screen at the bottom
2. Interface screen - showing PAW version 20220805
3. Configure Page.

« Last Edit: August 22, 2022, 09:19:21 am by exfirepro »

Admin

Re: Network Settings page not showing the GRID part
« Reply #1 on: August 08, 2022, 02:17:29 pm »
Hi Gary

I see ports 2 and 4 are configured for Trig and FLM

can you post a picture of the dongles plugged into the unit I am sure you have it correct, but lets start there.
Also as a test could you unplug the Trig and FLM, and set them back to Auto
remember to record your settings so you can revert correctly after the test

thx
Lee

Gary Nelson

Re: Network Settings page not showing the GRID part
« Reply #2 on: August 08, 2022, 03:46:36 pm »
See 2 x photo of the USB part (normal and close up). The Rosetta is normally velcroed but I peeled it off its mounting to access it to fit the dongle



exfirepro

Re: Network Settings page not showing the GRID part
« Reply #3 on: August 08, 2022, 06:14:40 pm »
Hi Gary,

Your WiFi dongle is in the bottom right USB port, which is Port 4, so that needs to be reconfigured to ‘Auto’ not ‘GPS’ and the change saved.

Port 1 is your GPS, but it will run fine with that port set to ‘Auto’.

Best Regards

Peter
« Last Edit: August 08, 2022, 06:16:45 pm by exfirepro »

Gary Nelson

Re: Network Settings page not showing the GRID part
« Reply #4 on: August 08, 2022, 06:32:54 pm »
Thanks Peter and will do that

I would like to correctly label on the configure page what each USB port is being used for. I can see from another post that the numbering is 1 top left 2 bottom left 3 top right 4 bottom right? So 4 is the Dongle which I will change to Auto. That leaves one being Flarm and one being GPS and I cant remember what the last one is for. Any idea from the photo. Also any idea from the photo which is which. I can't remember and would have to open the access hatch to find out but there are 50 or so small bolt screws to unscrew  ???



Dave jones

Re: Network Settings page not showing the GRID part
« Reply #5 on: August 08, 2022, 08:35:22 pm »
I think the other is your Pilotaware Wi-Fi!

Seanhump

Re: Network Settings page not showing the GRID part
« Reply #6 on: August 08, 2022, 10:21:38 pm »
I'd go with

1 GPS - 2 SDR
3 FLARM - 4 Wifi
Pilotaware user ...

exfirepro

Re: Network Settings page not showing the GRID part
« Reply #7 on: August 08, 2022, 11:02:51 pm »
Hi again Gary,

Post edited for clarification and after finding a mistake re my understanding of the reason for the FTDI lead in Port 2 - See Reply #13

Sean - nearly correct, but the ports are numbered 1 & 3 on the top then 2 & 4 on the lower row (so numbered 'vertically' starting from from the top of the left hand column next to where the Ethernet Port is).

Gary - You don't 'Label' the ports on the Configure Screen. You 'select' appropriate settings to enable the transfer of specific data for a specific task - such as the one you have which is set to 'Transponder Funke'. This setting ensures that the correct data is transferred via the port at the correct speed (Baud rate) for your Funke Transponder. If it was a Trig Transponder, this port would instead be set to 'Transponder Trig' at 9600 Baud, or if the lead was being used to integrate Flarm from a Flarm device into the PilotAware - it would need to be set to 'Flarm-In' - each with their appropriate 'Baud Rate'. The other ports should simply be left as 'Auto' unless they need to be configured for a specific task -

For the avoidance of doubt, from your photos...

Top Left is Port 1 - which is your remote Mouse GPS.

Bottom Left is Port 2 - which is the FTDI RS232 Serial to USB converter for directly integrating Flarm data to PilotAware from your FlarmMouse.

Top Right is Port 3 - which is the 1090 Receive SDR

Bottom Right is Port 4 - which is your new WiFi Dongle.

All ports which don't specifically need particular settings should be left / set to 'Auto'. In your case this means all ports except Port 2, which should be reset to Flarm-In.

Best Regards

Peter
« Last Edit: August 13, 2022, 08:47:29 pm by exfirepro »

Admin

Re: Network Settings page not showing the GRID part
« Reply #8 on: August 09, 2022, 08:01:39 am »
From the manual, port identification

https://www.pilotaware.com/knowledgebase/configuration

Also Gary you say this
Quote
one of the 4 is used to input a Flarm mouse

Do you really have a flarm mouse, or a gps mouse ?
Thx
Lee
« Last Edit: August 09, 2022, 08:04:06 am by Admin »

exfirepro

Re: Network Settings page not showing the GRID part
« Reply #9 on: August 09, 2022, 09:45:01 am »
Hi Lee,

From memory I recalled previous confusion about a 'Flarm Mouse', so checked back Gary's previous posts just to be sure. As I suspected, Gary has a GPS Mouse (in place of the standard Rosetta GPS - as the Rosetta is mounted in the 'preferred' Eurostar position - inside the aircraft bodywork between the dash and engine firewall) and a Funke Transponder (hence the FTDI converter). We established in the earlier thread (back in January) that there is NO Flarm Mouse installed in Gary's plane, just the equipment I have listed above, so presumably resetting Port 4 to Auto and 4800 Baud should allow the WiFi dongle to be recognised.

Regards

Peter
« Last Edit: August 09, 2022, 10:08:46 am by exfirepro »

Gary Nelson

Re: Network Settings page not showing the GRID part
« Reply #10 on: August 10, 2022, 02:27:07 pm »
Thanks for advice to date:

As per attached screenshot of the PAW Configure page, I have now changed the USB port labels so Ports 1, 3, 4 are set to Auto and Port 2 is set to the Funke transponder. However, this has not cured the problem. I still cant see the lower part of the Network Screen to input the hotspot password from my phone. :-\


NB:  As per second attachment, a photo of the sill above my instruments, you will see, as I have labelled on this photo, that I do in fact have (1) a FLARM mouse (2) a PAW GPS and (3) a Karnardia Horis 57 GPS. I believe it is this Horis GPS that the Funke is connected to for position data and so I guess Port 2 is ??  :-\

« Last Edit: August 10, 2022, 02:30:29 pm by Gary Nelson »

Admin

Re: Network Settings page not showing the GRID part
« Reply #11 on: August 10, 2022, 05:00:11 pm »
Hi Gary

did you try my experiment of the following ?
(remembering to save your current settings)

only plug in the following

- SDR
- GPS
- WiFi dongle

configure all to Auto/4800
Reboot
What does the display show

If this fails - it sounds like a fault

thx
Lee

Gary Nelson

Re: Network Settings page not showing the GRID part
« Reply #12 on: August 10, 2022, 05:17:42 pm »
Lee I will try your experiment when next at airfield and report back. It means I have to again unscrew 50 odd small bolts to take off the access panel on my Eurostar and then all have to be screwed back on (I only did it last week to fit the new dongle)  :(

exfirepro

Re: Network Settings page not showing the GRID part
« Reply #13 on: August 13, 2022, 08:44:39 pm »
Hi Gary,

Sorry, I have to eat Humble Pie and apologise profusely - Having spent a full day re-reading all of your many previous posts and threads, I now realise I got things completely confused re your Flarm Mouse and Funke Transponder connections, so have adjusted my posts above accordingly.

For the avoidance of doubt, the correct response to your photos should have been: -

Port 1 (Top Left) is your remote Pilotaware GPS Mouse (Settings should be - Auto and 4,800 Baud)

Port 2 (Bottom Left) is the FTDI USB to RS232 Serial Converter - which in your case is being used 'in reverse' to connect your FlarmMouse to your Rosetta to allow direct integration of directly received Flarm data from the FlarmMouse into Pilotaware. This port should therefore (of course) be set to 'Flarm-IN' and '19,200 Baud'

Port 3 (Top Right) is the 1090 Receive SDR (Settings again - Auto and 4,800 Baud)

Port 4 (Bottom Right) is your new iGRID WiFi Connectivity Module (Settings again - Auto and 4,800 Baud)

If you want to avoid removing all the screws (yet again) to get to the Rosetta, you could try resetting the USB ports to the above settings, then 'SAVE' the settings,  reboot the PilotAware and see whether the WiFi Connectivity Module comes on line. If not, then you need to try Lee's setup (i.e. unplug the FTDI connection and set all 4 ports (temporarily) to 'Auto' and 4,800 Baud).

Again, my apologies for any confusion caused.

Best Regards

Peter
« Last Edit: August 13, 2022, 08:50:49 pm by exfirepro »

Admin

Re: Network Settings page not showing the GRID part
« Reply #14 on: August 14, 2022, 08:12:15 pm »
Hi Gary
If I recall correctly, you should not require a gps mouse, the flarm mouse will provide gps messages
Thx
Lee