Author Topic: Unable to Connect to PAW on Android due to QR Code (Solved)  (Read 1053 times)

Planespeaker

I received my Pilot Aware Rosetta in February 2021, connected to the PAW site and input all the required information.
Due to lockdowns I've not had a chance to use it "in anger" until last week when I took the opportunity to try it out whilst sitting in my aircraft on the ground at Sandown, where there was plenty of traffic to sample. Power is from an Anker Powercore10000. An Aircew flight instrument is connected by lead to the Rosetta carrying power, GPS and conspicuity information. A Huawei tablet running EasyVfr4  connects to Rosetta via a WiFi link.
Nothing appeared on the tablet but several contacts showed on the appropriate page of the Aircrew, although hex number identification not registrations.
Thinking to check the settings I attempted to access PAW as I had before but now, although my tablet recognises PAW it will not connect. Instead a popup appears headed by the identification of my Rosetta and a QR code inviting me to "scan the code to connect to this WiFi network"
Levels of of frustration are rising into the red. What am I doing Wrong?
« Last Edit: December 02, 2021, 10:21:01 pm by exfirepro »

exfirepro

Re: Cannot access PaW
« Reply #1 on: May 02, 2021, 03:13:09 pm »
Hi Planespeaker,

I've certainly never seen (or heard of) that message before, so that's a new one on me, (though I have seen similar responses as detailed below).

I think this may be to do with recent security updates introduced by both Apple and Android to protect their devices from connecting to 'unrecognised sites'  - particularly those with NO external internet access - which is exactly what PilotAware tells the applications it is.

If I'm reading correctly, you have confirmed that you have your tablet connected to the PAW WiFi Hotspot, so that part seems OK, but that entering the URL 192.168.1.1 in your browser simply brings up the warning and QR code you report.

If this is the case, the best option is to tell the tablet to 'Forget this WiFi link', also delete any presaved links to 192.168.1.1 in your browser and completely shut down EasyVFR. then shut down and restart the tablet, reconnect to the PAW WiFi hotspot and restart your browser (presumably google chrome). Now create a new link by entering 192.168.1.1 exactly as shown here (but not in bold). Check carefully that the device hasn't automatically added http:// or https:// to the start of this 'URL' - which denotes that it is trying to connect to a secure internet site, then press 'Go' (or 'Enter' depending on your keypad). This should allow the connection. If so, when you start EasyVFR, your device may well also ask you to confirm that you are happy to allow EasyVFR to connect to PilotAware (it being an 'unknown' site or words to that effect). Mine certainly did when I started using SkyDemon after these updates. Agreeing to the connection should solve the problem.

Sorry, I'm not an EasyVFR user, but know a man who uses both EVFR 3 and EVFR 4 on Android, who should be able to help if needed.

Please let me know how you get on.

Best Regards
Peter

p.s. Just a word of warning. I also run Aircrew, and am aware that the Aircrew Manual advises that Aircrew can be powered from PilotAware via USB cable, but we have had a recent case where an Aircrew powered from PilotAware in this way may have been partly responsible for causing undervoltage reports in the PilotAware, so please just keep an eye out for any such reports, which would be reported on the PilotAware Home Screen via login to 192.168.1.1 as Voltage Warnings or Throttling. Hopefully this won't apply in your case.
« Last Edit: May 02, 2021, 03:15:13 pm by exfirepro »

PaulSS

Re: Cannot access PaW
« Reply #2 on: May 03, 2021, 01:05:16 am »
Planespeaker, are you based at Sandown? If so, let me know and I will try to arrange a meeting in an attempt to troubleshoot your kit. I'm certainly no expert but mine has always worked just fine, so we might be able to compare and contrast  :)

Planespeaker

Re: Cannot access PaW
« Reply #3 on: May 03, 2021, 10:07:01 am »
Hello Peter and thanks for your reply. I have tried what you suggested but got nowhere, always ending up with the QR code request shown in the attached screenshot. My next step may be to strike my Rosetta with a large hammer.

James Rose

Re: Cannot access PaW
« Reply #4 on: May 03, 2021, 12:08:45 pm »
That QR code is for sharing the WiFi network to other phones. It looks like your phone is connected to PilotAware.

Can you open up the browser, goto 192.168.1.1 and then send a screenshot of what that page looks like?

As Peter said if you don't see the PilotAware homepage on 192.168.1.1 then it's most likely because Android devices do not like connecting to WiFi networks with no internet. You should be able to fix this by:

1) Open the WiFi settings for the PilotAware hotspot
2) Click "forget" so you disconnect from the PilotAware hotspot
3) Reconnect to the PilotAware hotspot, and wait for the "Internet may not be available" message to pop up
4) Click "Keep Wi-Fi" connection
5) Open your browser and go back to 192.168.1.1




Also regarding only seeing HEX on Aircrew:  PilotAware only sends HEX ICAO over USB due to combability for legacy FLARM products - it may be better to power your Aircrew separately and connect Aircrew to PilotAware over WiFi, then you'll get the registrations.

exfirepro

Re: Cannot access PaW
« Reply #5 on: May 03, 2021, 01:41:49 pm »
Hi again Planespeaker,

Thanks for the feedback.

Please don’t take it out on your Rosetta. To be quite blunt the fault lies with Android and your Device Developer - It’s nothing whatever to do with PilotAware.’

Remainder of post edited significantly after an epiphany! - see below

I agree with James, your Tablet is clearly already connected to the PilotAware WiFi Hotspot, but you can’t get past that point because the QR Screen is blocking progress. I initially had no idea what was generating the QR code or what it was for, and I have been an Android User for years. I currently use a Samsung Galaxy S9+, so not the most modern Android device, but running Android 10 and I can honestly say I have never seen that ‘QR’ response to a WiFi or App Connection before on any device. (I also use iPads in flight - and to type this response to the Forum, so it’s definitely a new one on me!)

Logging onto the PAW Home Screen via the 192.168.1.1 URL is of course a completely separate issue carried out via your (presumably Chrome) browser once you have established a solid WiFi Connection, and is nothing to do with the WiFi Connection per se, though it might well trigger the ‘Internet may not be available’ warning - which James has described and which is what I was referring to in my earlier post, I just couldn’t recollect the wording. In James’s screenshots, the system is warning you that you are trying to connect to a site without internet (which may be dodgy). If you accept the risk and acknowledge the lack of internet access by clicking on the ‘Keep WiFi Connection’ button, your device should simply remember this whenever you try to connect to PAW in future. However I’m now sure that isn’t the problem in your case!

After posting, it occurred to me that you obviously can’t scan the ‘QR’ from the device it’s displaying on, which got me thinking. Out of interest, I scanned the QR code from your screenshot with my Galaxy S9+ and magically, up pops a button on my screen which says ‘Tap here to connect to this WiFi network’. Clicking on the button, my phone attempts to find the WiFi Hotspot for your PilotAware, which is obviously not present on my phone, so it just ignores the instruction. That confirms James’s comment that the QR code is intended to be scanned by a different phone or tablet to allow that device to connect to the same WiFi access point (but why make it so complicated? If you want to connect more than one device to your PAW you simply connect each in turn to the PAW WiFi Hotspot!).

That all being the case, however,  simply clicking ‘Cancel’ should delete the QR screen, leaving your tablet connected to your Rosetta. If you click ‘Forget’, I’m guessing it forgets the WiFi Hotspot- so you are back to Square 1. If I’m correct, you then just need to open your browser and do the 192.168.1.1 bit as per my earlier post, and of course connect EasyVFR ready to go flying - but that’s an area I can’t easily help you with (the EasyVFR setup, not the flying) but as stated earlier, I know a man who can if you need help.

Hopefully this is now the correct answer  ::).

Regards

Peter
« Last Edit: May 03, 2021, 02:37:55 pm by exfirepro »

Planespeaker

Re: Cannot access PaW
« Reply #6 on: May 03, 2021, 05:07:22 pm »
Thank you Peter. Your solution worked. It seems so simple now and just goes to underscore that air traffic controllers shouldn't be trusted with technology. I have laid aside the hammer.

exfirepro

Re: Cannot access PAW on Android due to QR Code (Solved)
« Reply #7 on: May 03, 2021, 05:33:56 pm »
Great News,

Just for completeness, I have been chatting to James and it seems the QR Code is designed as a simple (?) way to allow friends to connect to your (home) WiFi, without having to give them the password. I need to do a bit more research, but at least we (and anyone else reading this) now know how to deal with it.

Regards

Peter

Perhaps one of the Mods would update the thread title to ‘Unable to Connect to PAW on Android due to QR Code (Solved)’ to help any future searchers.
« Last Edit: May 03, 2021, 05:37:21 pm by exfirepro »