Author Topic: Sky Demon not connecting with PA  (Read 1966 times)

Rogerpenney

Sky Demon not connecting with PA
« on: April 17, 2021, 10:07:36 am »
I am using an iPad mini with the latest IOS 14.4.2 software and also an iPhone 11 max with the latest software.
I last flew in December 2021 and all was working fine. My Rossetta has the latest firmware.
I just use the iPad for nav. The phone is backup.

On 15/4/21 the iPad  would not navigate. Wifi is connected ok, when I press ‘go flying’  the connection does not complete. iPhone and iPad  have had software updates since I last flew.

It DOES work when I connect to the iPhone!

I have reloaded the PA firmware, power supply and cable  is good, PA is operating normally when  I connected to ipad, its seeing traffic and all items are green.

I have read numerous posts from last year on this subject and nothing I have done  fixes it.

exfirepro

Re: Sky Demon not connecting with PA
« Reply #1 on: April 17, 2021, 11:38:14 am »
Roger,

When you last flew, your devices were presumably using the older iOS /iPadOS firmware.

Have you tried telling the device to ‘forget’ the PAW Wifi link, then completely shut down SD via its ‘Settings / Log Out’ option, then shut down the app itself by double clicking the iPad ‘Home’ button and ‘wiping’ SkyDemon off the apps screen (beware you will need your SkyDemon password and WiFi access to log back in afterwards), and completely shut down your iPad.

Next restart the iPad, then restart SkyDemon - which will require you to re-login via their website using your SkyDemon Password - then recheck your SD connectivity settings (in Third Party Devices). Now connect to the PAW WiFi hotspot, check that you can see the PAW screens via 192,168.1.1 and that you have 4 x 'Greens' (or at least 3 + the orange 1090) on your PAW Home Screen. Now select 'Go flying - use PilotAware' in SkyDemon. This should trigger the iPad to ask you to confirm agreement to using SD on what iOS sees as an 'unrecognised local network' (or words to that effect). Acceptance of this prompt should add SD to the ‘approved Local Network list’.

Edit: See further details posted below.

Regards

Peter
« Last Edit: April 19, 2021, 08:05:48 am by exfirepro »

Admin

Re: Sky Demon not connecting with PA
« Reply #2 on: April 18, 2021, 07:24:31 pm »
The latest IOS  14.4.2  has added some security for locally connected devices
You have to enable this to allow the iPad Apps to talk to PilotAware

Thx
Lee

exfirepro

Re: Sky Demon not connecting with PA
« Reply #3 on: April 18, 2021, 07:59:54 pm »
Ah yes of course - although that is what I was alluding to in the original version of my above post, I forgot to include the specifics, so have revised my earlier post accordingly.... See below   :-[

Roger, you need to make sure SkyDemon is listed in ‘Settings / Privacy / Local Network’ on your iPad. If not, the (edited) process I refer to above should prompt SD to request addition to the list of apps approved for connection to the Local Network. (If not I need to have a further look at this). My own iPadOS 14.4.2 iPad mini 5 currently has 3 apps listed in the ‘Local Network’ folder, namely ‘Aircrew Update’, ‘PAW Firmware Updater’ and ‘SkyDemon’, though others will obviously vary - yours, for example, may well currently list no apps at all.

N.B. For anyone else reading this, it ONLY applies to devices running the more recent versions of iOS / iPadOS14. The ‘Local Network’ field does not exist on earlier versions of iOS. And for all you Android Users out there feeling smug, you have your very own version waiting to trip you up shortly.

Regards

Peter
« Last Edit: April 19, 2021, 08:21:20 am by exfirepro »

Rogerpenney

Re: Sky Demon not connecting with PA
« Reply #4 on: April 20, 2021, 01:01:32 pm »
Thanks that worked but I couldn’t log back into Demon App as it did not  recognise my password. I could get into Demon website with it though!

After changing password several  times still no luck. I then sought help from Demon helpdesk.
Answer......

Dont use any symbols in your password!! I was doing so.

I changed Demon password using only letters and numbers and all was fine.

What a faff.

exfirepro

Re: Sky Demon not connecting with PA
« Reply #5 on: April 20, 2021, 01:08:44 pm »
Hi Roger,

Strange - I have a symbol in my SD Password and it works fine, but there is usually a very limited range of symbols that are acceptable in passwords.

Glad to hear that you now have the connection issue sorted though. That’s the important bit.

Best Regards

Peter